
 

 
 

 

TELANGANA TRIBAL WELFARE 

RESIDENTIAL DEGREE COLLEGES 

 

 
 

BRIDGE COURSE MODULE 

2022 
Department of Computer Science 

TTWRDC (W)-DEVARAKONDA 

  
 

Computer Science is the Operating System for all Innovation. 

 

 

 
  



 

 
 

 

INDEX 

 

MODULE CONTENT PAGE NO. 

1 INTRODUCTION TO COMPUTER 

• Computer hardware, Definition. 

• Input devices 

• Output devices 

• Components of computer system 

1-6 

2 MEMORY 

• Definition and memory unit 

• Generations of computer  

7-12 

3 OPERATING SYSTEM 
• Functions of operating system 
• Types of Operating system 

 

13-16 

4 Understanding Desktop icons 17-18 

5 WORD PROCESSING 

• Microsoft word 

• Parts of a MS-WORD Window 

• Headers and Footers 

• Mail Merge 

19-36 

6 WORK SHEET/ SPREAD SHEET 

• Work books 

• Functions 

37-49 

7 PRESENTATION 

• Creating a New Presentation 

• Master view 
  

50-54 



 

 
 

8 INTERNET 

• History of internet 

• Internet Architecture 

55-58 

9 WORLD WIDE WEB 

• Electronic Mail 

59-61 

 



 

1 
 

1. INTRODUCTION TO COMPUTER 

 
Objectives of Basic Computer Skills: 
1. To develop skills of computer science for fresher’s 

2. Avoid fear of computer system 

3. To build awareness about computer security 

 

 

1.1 Introduction to computer hardware 
Computer hardware is the physical components that a computer system 

requires to function. It encompasses everything with a circuit board that operates 

within a PC or laptop; including the motherboard, graphics card, CPU (Central 

Processing Unit), ventilation fans, webcam, power supply, and so on. 

 Introduction:  
The term computer is derived from the Latin word compute, which 

means to calculate. A computer is a tool and partner in every sphere of 

human life and activity. Computers are bringing many changes in 

industry, government, education, medicine, scientific research, law, 

social service. 

  
Definition: 

A Computer is an electronic device that processes data and 

converts it into information that is useful to people. 

What is the full form of computer? 

C- Commonly 

O- Operated 

M-Machine 

P- Particularly 

U- Used for 

T- Technical 

E- Educational and 

R-Research 
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1.2 INPUT and OUTPUT devices  
The devices that are used to enter data and instructions into the 

computer are known as Input devices. 

 

Input Devices 

  
It includes Keyboard, Mouse, touchscreens, Joysticks, barcode readers, 

scanners, etc. 

  
Keyboard: 

A keyboard is the primary input device. It can be used to enter the text 

input. A standard keyboard contains about 100 keys. It contains Typing 

keys, numeric keypad, Control keys, function keys, cursor keys and 

special purpose keys. The computer keyboard uses the QWETY key 

arrangement. 

  
Mouse: 

 

A Mouse is a graphical input device. You can move the mouse 

around a surface and controls the pointer. By using the mouse, you 

can perform: 

I. Clicking 

II. Double-Clicking 

III. Dragging 

IV. Right Clicking 
 
 

There are two types of Mouse’s: 
 
1.Physical Mouse 
 
2.Optical Mouse 
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Touch Screen:  
A touch screen is a type of screen that allows you to input by touching 

its icons. 

 

Joystick: 

A Joystick is a game controller. It is a swivelling lever. It is well suited 

for playing video games. 

 

 

Scanner: 

A scanner is an input device. It can scan a document or an image 

into the computer's memory. Microphone 

A Microphone enables you to input your voice or music as data. 

Microphones are useful for audio and video conferencing. 

 

 

Barcode readers 

Barcode readers are one of the most widely used input devices. 

They can read the bar codes on the products. 
 
 

 

1.3 Output Devices:  
The devices that can display the resulting information to the user are 

known as Output devices. 

Monitors and Printers are commonly used output devices.  
Monitors.
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Monitor is a commonly used output device. It is also called as Visual 

Display Unit (VDU). It provides  
A visual display of data.  
Monitors are of different types: 
 
1. CRT( Cathode Ray Tubes) 
 
2. LCD(Liquid Crystal Display) 
 
3. LED (Light Emitting Diode)  

Printers:  
A Printer is an output device that prints text or images on paper. 

Printers are useful to create ‘hard copy’ of data.  
Printers are of two types: 
 
1. Impact printers 
 
2. Non‐impact printers. 
 
Impact printers:  
Impact printers can print by striking the paper. Example: Line printers, 

dot-matrix printers. 

Non-impact printers:  
Non-impact printers do not 

strike the paper. Example: 

laser printers, inkjet printers. 

Plotters:  
Plotters are the output devices. They can print the data or images on a 

large sized papers. 

Speakers:  
Speakers are output devices that allow you to hear sound from your 

computer. Computer speakers are just like stereo speakers. 
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1.4 The basic components of a Computer system 
  
The basic components of a computer can be classified into four main 

units: 
 
1.Input Unit. 
 
2.Central Processing Unit 
 
3.Memory Unit 
 
4.Output Unit 
 
Input Unit:  
Computer uses input devices to accept the data and program. Keyboard, 

mouse, light pen, touch screen etc., are some of the input device. 

 

 

Figure: Basic components of a Computer System
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. 
Central Processing Unit: 
 
CPU is the brain of any computer system. It Coordinates all 

computer operations and Perform arithmetic and logical operations 

on data.  
 
 
 
 
 
 
 
 
 
 
             

 

                                   Figure: CPU  
The CPU consists of arithmetic and logic units, control unit and internal 

memory (registers). The Control unit controls all the operations. The 

arithmetic and logic units performs addition, subtraction, division and 

multiplication and some logical operations. 

 

Memory: 

The electronic storage are of a computer is known as Memory. 

Computers memory is of two types: 

• Primary Memory (or) Main Memory 

• Secondary Memory 

The main memory stores the programs and data that are currently 

being used by the computer. It holds data and programs temporarily.  
Secondary memory stores the data permanently. It is also known as 

auxiliary memory. It is much less expensive. 
Output Unit:  
Output devices can display the resulting information to the user. 

Monitors and Printers are commonly used output devices. 
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2. Memory 

 
                The storage areas of a computer is known as 

Memory. Memory is useful to hold / store data and the instructions. 
 

 MEMORY UNIT: 

 

UNIT ABBREVIATION STORAGE 

Bit B Binary digits either 0 or 1 

Nibble - 4 bits 

Byte B 8bits 

Kilo Byte KB 1024 bytes 

Mega Byte MB 1024 KB 

Giga Byte GB 1024 MB 

Tera Byte TB 1024 GB 

Peta Byte PB 1024 TB 

Exa Byte EB 1024 PB 

zetta Byte ZB 1024 EB 

Yotta Byte YB 1024 ZB 

 
 

:
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Computer’s memory is of 2 types: 

 

 

1. Primary Memory. 
 
2 .Secondary Memory. 
 
Primary Memory:  
Primary Memory is also called as main memory. There are different types of 

memory. They are: 

I I. Random Access Memory (RAM) 

II. Read Only Memory (ROM) 

Random Access Memory – [RAM]: RAM is the main memory for a computer. 

RAM can be used for both reading and writing. When we switch off a 

computer, then the data on RAM will be erased. It is a volatile memory.  
TYPES OF RAM: 

There are two types of RAM: 

•• Dynamic RAM 

•• Static RAM.  
 
Dynamic RAM (DRAM): Its data has to be refreshed after every few milliseconds. 

DRAM has higher storage capacity. It is cheaper than Static RAM.  
Static RAM (SRAM): Its data need not be refreshed. SRAM has higher 

speed. It is costlier. Read Only Memory – ROM 

ROM is computer’s internal memory. It contains some pre-loaded programs. The 

programs on ROM are helpful for booting. 

There are different types of RAM: 
 
1.ROM 

2.EPROM 
 
3.EEPROM 
 
PROM: It is a Programmable ROM. PROM allows us to write our own BIOS 

programs. But these programs can be written only once.  
EPROM: It is Erasable Programmable Read Only Memory. EPROM allows us 

to write our own BIOS programs. These programs can be erased by using an 

ultraviolet light. 
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EEPROM: It is an Electrically Erasable Programmable Read Only Memory. 

EEPROM allows us to write our own BIOS programs. It can be erased by exposing 

it to an electrical voltage. 

Register 

Registers are the high speed storage areas within a CPU. They are also called as 

CPU’s Working Memory. They are useful to the CPU during the execution of 

the instructions. There are different types of registers:  
Accumulator (ACC): It can store the results of arithmetic and logical operations 

Instruction Register (IR): It contains the current instruction. 

Program Counter (PC): It contains the address of the next instruction. 

Memory Address Register (MAR): It contains the address of the next location in 

memory. 

Memory Buffer Register (MBR): It temporarily stores the data from memory. 

Data Register (DR): It stores the Operands and other data.  
CACHE Memory 

A Cache is a fast responding, small memory chip attached between CPU and 

memory 

 

 

1. CACHE memories are accessed faster than RAM. 

 
 
2. It is used to store programs currently using by the CPU. 
 
3. So cache memory makes main memory to work faster. 

 

4. A Cache is available in limited 

 

Capacity (in Kilo Bytes.



 

10 
 

Figure: Cache Memory  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

CACHE is of 3 Types:  
• • Level-1 Cache 

• • Level-2 Cache 

• • Level-3 Cache 
 
Secondary Memory / Storage Devices:  
Secondary memory is a large, non-volatile memory. It stores the data 

and instructions permanently. Some of the commonly used secondary 

storage devices are hard disks, magnetic tapes, floppy disks and CD-

ROM 

 

Hard Disk: 

Hard disk is a magnetic disk. It can store computer data and instructions. 

It is a direct-access storage medium. A hard disk contains some Tracks 

and Sectors to store the data. The arrangement of tracks and sectors on a 

disk is known as its ‘format’Now a days the hard disk in a PC has nearly 

1Tera Byte Capacity.  
Now a days the hard disk in a PC has nearly 1Tera Byte capacity. 
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Magnetic Tape: 

A magnetic tape is a thin tape with a coating of magnetic strip. It is used 

for recording the data. 

Magnetic tape is a serial access medium. Magnetic tapes are generally 

used for backup.  
Floppy Disk 

 

A Floppy disk is a thin circular disk used for data storage. It is a 

soft magnetic disk that can be enclosed in a protective sheet. It 

contains tracks and sectors.  
A floppy has 3.5" in size. Some floppy disks would be 5.25" in size. A 

3.5" floppy disk can hold 1.44 MB of data 

 

 

 

Compact Disk 
 
Compact disk is a secondary memory device that can be written by 

lasers. It is a random access storage medium. It is also known as 

read/write CD-ROM. It is a popular and cheap method for storage.
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.  

.  
Floppy Disk Internal Structure Compact Disk  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2.1 
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3. OPERATING SYSTEM 
  
             Definition: Operating System (OS) is system software. It acts 

as an interface between the user and the computer hardware. 

Objectives of OS:  
OS has two main objectives: 
 
(1) To make the computer system convenient and easy to use. 
 
(2) To use the computer hardware in an efficient way. 
 
Examples of OS:  
Some commonly used operating systems are: Microsoft Disk 

Operating System (MS-DOS), Windows XP, Windows 7, 

Windows 8, Windows 10, UNIX, Linux, Mac, Android, etc. 

 

3.1 Functions of OS 

 
The following are the main functions of the OS: 
 
1.Process Management 
 
2.Memory Management 
 
3.File Management 
 
4.Device Management 
 
5.Protection and Security 
 
6.User interface 
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                                             Figure: Functions of OS 
 
Process Management: 
 
A process is a unit of work. A process can be created, executed and 

stopped by the operating system.  
A process may have 5 states: 

I. New State  

II. Ready State 

III. Running State 

IV. Waiting State  

V. Terminated State 

 

The following figure shows the 5 states:  
 
 
 
 
 
 
 
 
 
 
 
 

 

 

                             Figure: Five State Process Model  
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Memory Management: 

 

Every process requires some memory. OS performs the memory 

management functions like: 

I. Allocate memory II. Free memory  
III. Re-allocate memory IV. Maintaining the memory usage details. 

 

 

File Management: 

A file is a collection of related information. OS manages a collection 

of files and directories. It can create and delete files.  
Device Management: 

OS controls and manages the devices connected to the computer. It 

can communicate with the devices by using device driver software. 

Protection and Security: 

 

OS protects the resources of the system. It provides the basic 

protection like user authentication, encryption, backup, etc. 

User interface:  
OS provides an interface between the user and computer. It allows 

the user to interact with the application and the hardware. 
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3.2 Types of Operating Systems  
  
OS are of the following types: 
 
1.Single User -Single Tasking Operating Systems 
 
2. Single User -Multitasking Operating Systems 
 
3.Multi User Operating Systems 
 
4. Multiprocessing Operating Systems 
 
5. Real time Operating Systems 
 
6. Embedded Operating Systems. 
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4. Understanding Desktop Icons: 

 
The Windows desktop contains a range of icons, some of which appear 

when you install Windows 10, and some that appear when you install 

new programs. Icons with an arrow are known as shortcuts or links to 

programs, files or folders. You can doubleclick on a desktop icon to 

launch that program, folder or file. Below are some common desktop 

icons. 
 

 

 

Icons What They Represent 

 

Programs 
The icons to the left represent shortcuts to 

various programs. You can tell it’s a shortcut as 

it contains an arrow. So, if you were to delete the 

shortcut, you wouldn’t be deleting the actual 

program, only the desktop link to it. Double-

clicking on the relevant icon will launch that 

program. For example, if you double-click on 

the icons to the left you will launch:  

1. Microsoft Word 2007 (word processing 

program)  

2. Mozilla Firefox (internet browser) 

3. Adobe Reader 9 (to view PDF files) 
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Files  

Icons that show a page represent a file. 

When you double-click on the icon, the 

file will open in the program that it was 

created in. The picture to the left shows 

that the file was created in Notepad. 

However, as no arrow appears, it is not a 

shortcut, but indicates that this file was 

actually saved to the desktop. Therefore, if 

this desktop icon is deleted, so is the 

actual file. 

 

Folders and drives  

Icons that show a folder represent a folder 

or shortcut to a folder. When you double-

click on a folder icon, the Windows 

Explorer window will open and you will 

see the contents of that folder. Similarly, 

icons that show a hard disk will display 

the contents of that drive in Windows 

Explorer when you double-click on it. 

 

Recycle Bin 

 The desktop icon for the Recycle Bin is 

shown as a waste paper basket with the 

recycle symbol on it. Double-clicking on 

this icon will open the Recycle Bin 

window, allowing you to permanently 

delete or restore files as necessary. 
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5. WORD PROCESSING 

 

Application of word processing:  

The process of using a computer to create, edit, format and print 

documents is known as Word Processing. 
 
• To perform word processing, a 
computer, a special program called a word processor and a 
printer are required. 
A word processor is an application program that enables the 

user to create a document, format it, store it, display it and 

print it on a printer. 

• Microsoft Word is the most widely used word processing 

software. 

• WordPerfect and open Office Writer, Libre Office Writer 

are some other word processers. 

• Office Web Apps or Google Docs are the Web-based word 

processors. 
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 Microsoft Word 2013 is a word-processer that is used to 

create professional-looking documents such as reports, 

resumes, letters, memos, and newsletters.  
• Word processors have a variety of uses in the business, home, 

and education. 

• In Business word processing is used for: 

*Letters and 

letterhead * Memos 

*Documents.  
• In the home word processing is used as educational, planning, 

dealing with assignments. Examples: 

*Letter writing * résumé/CV creation. 

• In education word processing is used the production of 

assignments, notes, exams, and for practicing its uses! 
 

5.1 Microsoft WORD 

 

Microsoft Word 2013 is a word-processing program that is used to 

create professional-looking documents such as reports, resumes, 

letters, memos, and newsletters. 

Features of word processing:  
Word processors/Microsoft Word has the following features: 
 
1. Text Manipulation 
 
It allows us to change the appearance of a document by changing words, 

sentences and paragraphs. 
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2. Document Formatting 
 
It allows us to format the documents. Formatting improves the 

readability of documents.  
 
3. Graphics 
 
It allows us to insert Pictures or graphics in a document. 
 
4. Tabs 
 
It allows us to setup the text on a page in the exact position. 
 
5. Tables 
 
It allows us to insert tables in a document. The data in a table can be 

sorted, formatted, etc. 
 
6. Mail Merge 
 
Mail merge allows the user to merge a list of names and addresses to a 

single letter that can be sent it to different people. 
 
7. Spell Checking 
 
It allows the user to check the words for correct spelling.  
Collaborative Editing: It allows two people to simultaneously work 

on one document as a team. 
 
Starting Word  
You can start Word 2013 from the Start menu. 

->To start Word 2013 from the Start menu: 
 
1. Click the Start button -> All Programs -> Microsoft 

Office 2013->Word 2013. 
 
• It shows the Start screen. 
 
2.In the right pane, click Blank document. 
 
• It opens a new, blank document. 
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5.2 Parts of a MS-WORD window  
MS-WORD is a word processor. An MS-Word window has the 

following 
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Menus and Tool bars:  
The old menu system has been replaced by the Ribbon and the Office 

button in the latest versions of Word. 
 
8. Title bar: It appears at the top of the window. It displays the title 

of the document. It also shows the buttons to minimize, restore, 

/maximize, and close the window. 
 
• Quick Access toolbar: It appears on the left side of the Title bar 

and contains frequently used commands. 
 
• Ribbon: It appears below the Title bar. It consists of a set of tabs with 

related commands/Menus. 
 
• Navigation pane: It appears on the left side of the window. It 

enables you to navigate long documents, search for specific text. 
 
• Document window: It displays the contents of the document. 
 
• Cursor: It is a blinking pointer that indicates where the text will be 

inserted. 
 
• Scroll bars: It enable you to scroll through the document. 
 
• Status bar: It appears at the bottom of the window. It displays 

information about the document 
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Creating Documents  
An MS-Word document can be created by using the following 

procedure 
 
1.Select and Click on Word 2013  
2.Select Blank document 

• It opens a new document for you to enter your content. 

3.You can also create a new document by pressing CTRL + N keys. 
 
 

Saving Documents  
After creating a document, you can save it.  

To save a new document: 

1.Click on the File tab 

2. Then, click on Save as It opens the 

Save As page window. Select a location to 

save the file 

3.Type a File name. 

4.Click the Save button.  
 
NOTE: 1.Word 2013’s file format is called Word Document. 

This format has the .docx file extension.  
2. You can also save a document in the Word 97-2003 format with the 

.doc file. This format works with earlier versions of Word. 

Closing Documents 

You can close a document after finishing working on it. 

To close a document: 

1.Click the File tab 

2.Then click Close. 

Or, press Ctrl+
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. 
 
3. Opening Documents  
You can locate and open an existing document. 

To open a document: 

1.Click the File tab 

2.Then click Open. Or, press Ctrl+O. 

• It opens a list of recently used documents. 

3.Locate your document and then click the Open button. 
 
Previewing and Printing Documents  
To preview and print a document: 

1.Click the File tab 

2.Then click Print. Or, press Ctrl+P. 

•It displays print settings 

3.Change the print settings as you like.  
To print the document, click the Print button. 
 
Editing Documents  

Most documents require some editing. You may perform basic 

tasks such as selecting,  
Deleting, copying, and moving text, and undoing and redoing changes. 
 
Selecting Text  
To select text: 

 

1.To select a word, double-click anywhere in the word. 
 
2.To select a sentence, hold down the Ctrl key and click anywhere in the 

sentence. 
 
3.To select a paragraph, triple-click anywhere in the paragraph 

 
4. To select the entire document press Ctrl+A
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Deleting Text  
To delete text: 

1.Select the text that you want to delete, and then press the Delete key.  
Moving and Copying Text 

You can copy or move the text 

into a location. To move or copy 

text: 

1.Select the text that you want to move or copy. 

2.Select Home tab and do one of the following:  
• To move text, click the Cut button. Or, press Ctrl+X. 

• To copy text, click the Copy button. Or, press Ctrl+C. 
 
3.Place the cursor in the required position.  
4.Then, Click the Paste button. Or, press Ctrl+V.  
Undoing and Redoing Changes 

Whenever you make a mistake, you can easily reverse it with the 

Undo command. The Redo command allows you to restore the 

undone actions. 
To undo an action: 

1.Click the Undo button. Or, press Ctrl+Z.  
To redo an action: 

1. Click the Redo button. Or, press Ctrl+Y. 

Formatting Documents 

Formatting is a feature that enhances the appearance of a 

document. Text formatting includes font, font size, font color, 

and etc. 
 
 
 
 
 
 
 
 
 

 

 

Figure: Font group  
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Different formatting features in MS-Word 

Word 2013 has a number of features to format a document. The 

following are some formatting features: 
 
 
Name Description 

Bold 

Makes the selected 
text bold 
(Example).   

 
 
Name Description 

Align Left 

Aligns the text at the left 

margin. This 

Centre 

Is the default alignment. 

Centres the text between the 

left and 

 Right margins. 

Align Right 

Aligns the text at the right 

margin. 

Justify 

Aligns the text at both the 

left and right 

 Margins. 

Formatting Paragraphs 

Paragraph formatting is the layout of a paragraph on the page. 

You can change a paragraph alignment, line spacing, and the 

space before and after it.  
Changing Paragraph Alignment 

Paragraph alignment refers to the position of a paragraph between 

the left and right margins 
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To change the alignment of a paragraph:  
1.Select the paragraph that you want to align. 

2.On the Home tab, in the Paragraph group, click the desired alignment 

button. 

5.3 Headers and Footers 
Headers and footers are the areas in the top and bottom margins of 

each page. 

• • You can insert text or graphics in headers and footers. 

• • For example, you can add the document title, page numbers, the 

author’s name, or a logo. 

• • A header and footer appears on every page.  
 
To insert a header or footer:  
 
1.Click Insert tab 
 
2.Then select the Header & Footer group and click on the Header or 

Footer button.  
 
 
 
 
 
 
 
 
 

 

 

 

Figure: Header and Footer group  
Then it opens the header and footer area in the document. 
 
3.Type the required text in the header area. 
 
4.Type the required text in the footer area. 
 
5.Apply the required Formatting features to the header and footer. 
 
6.After finishing, click on Close header and footer. 
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Inserting Page Numbers: 

Page numbers are the most common type of header or footer.  
To insert page numbers: 
 
1.Click Insert tab 
 
2.Then select the Header & Footer group and click on the Header or 

Footer button.  
 
 
 
 
 
 
 
 
 
 

 

 

Figure: Header and Footer group  
• Then it opens the header and footer area in the document. 

 
3.Select Insert Page Number arrow.  
4.Click on the required style. 

• It will insert the page numbers at the specified position. 

5.After finishing, Click on Close header and footer 
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Working with Tables  
Tables are commonly used to organize and present data. A 

table is made up of horizontal rows and vertical columns. 
 
 
 
 
 
 
 
 
 
 

 

 

 

Inserting Tables  
Word 2013 makes it quick and easy to insert a table into a document. 

To insert a table: 
 
1.Click in the document where you want to insert the table. 
 
2.Select the Insert tab 
 
3.Select the Tables group and click the Table button  
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4. Select the desired numbers of rows and columns. 

 

Working with Images  
Images can add visual interest to documents. Word 2013 allows you to 

insert images of .gif, .jpg,  
.png, .bmp, etc. into a document. 

To insert an image: 

1.Click in the document where you want to insert the image. 

2.On the Insert tab, click on the Pictures button 

3. It will display an Insert Picture dialog box,  
4. Locate and select the desired image and then click the Insert button. 

  
5.4 Mail Merge 
The mail merge is a process that combines a document with a data 

source to produce personalized documents.  
Document contains the text and graphics. Data source contains the 

addresses of the recipients.  
The mail merge process in Word 2013 has the following steps: 
 

Select the document type and main document. 
 

Connect the main document to a data source and define the recipients 

list. 
 

Add merge fields to the main document. 
 

Preview the results and complete the merge. 
 
 

 

 

To perform mail merge: 
 
1.Create a new blank document and type your letter. 
 
2.Select Mailings tab and click on Start Mail Merge button. 

 

3. Then click Step-by-Step Mail Merge Wizard. 
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4. It displays the Mail Merge pane. It has the following 6 steps: 

 

 

Step 1 of 6: Select document type and select the Letters option.  
Step 2 of 6: Select starting document and select the Use the current 

document option. 

Step 3 of 6: Select recipients, select Type a new list option and then 

click the Create link 
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• Type the information of the recipients and save it.   
• Click the Next link. 

 

• Step 4 of 6: click in the document and insert a merge field. 

• Step 5 of 6: Click Preview your letters, click the Next button. 

• Step 6 of 6: Select Merge and click on Print. 

 

 

 

 

 

 •  
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• The following figure shows mail merge process: 

•  

 
 

 

 

 

 

 Figure: Mail merge Process 
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Macro  
Definition: A macro is a series of actions. 

You can use it to automate a repeated task. So that you can run the 

macro when you have to perform that task. It saves time for us. 

Creating/Recording a Macro: 

The following are the steps to record a macro:  
 
1.Click View > Macros > Record Macro.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
2.To assign your macro to a button, click Button. 
 
3.Select new macro and click Add. 
 
4.Click Modify. 
 
5.Choose a button image, type the name you want, and click OK twice. 
 
6.Now record the steps. 
 
7.To stop recording, click View > Macros > Stop Recording. 
 

• The button for your macro appears on the Quick Access Toolbar. 
 

• To run the macro, click the button. 
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Run a macro 

  
 
Steps to run a macro:  

You can run a macro by: 

• Clicking the button on the Quick Access Toolbar 

• Pressing the keyboard shortcut. 

• Run the macro from the Macros list. 

 

 
 
• 1.Click View > Macros > View Macros 

 

 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

2.Select your Macro name from the list. 
 
3.Click Run.   
Disadvantages of Macros: 

Some macros can give security problems. Sometimes hackers 

can introduce a destructive macro in a file that can spread a virus on 

your computer. 
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6. WORKSHEET 

 
SHEET Application of 

work sheet/spread sheet:  
A spreadsheet is a program that contains a group of ‘cells’ arranged in 

rows and columns. You can enter the data into each cell. This data can 

be used to make calculations, show graphical representations or 

analysis. 

• Spreadsheets are the widely used applications for analysing and 
displaying data. 

• Spreadsheets can help users to develop graphs, charts, reports of 
financial data, or statistical 

Analyses. 

• They has a wide variety of features including graphics, sorting, 

mathematical and statistical computing. 
• A spreadsheet can contain a number of different worksheets.  
• Spreadsheet software packages can be used on almost any type of 

computers. 

• The most widely used spreadsheet software packages are: 

->Microsoft Excel  
->Liber Office - Calc (Free) 

->Open Office - Calc 

->Google Sheets 

Microsoft Excel  
Microsoft Excel is a spreadsheet program that is used to manage, 

analyse, and present data.  
• It can be used to organize and manipulate large amounts of data, 

perform complex calculations, and more. 
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MS-Excel window also has the following menus:  
File: It contains the commands for managing the excel files. 

Home: It contains the most frequently used commands.  
Insert: It contains the commands to insert the required items into a 

worksheet. 
 
Page Layout: It contains the commands to change the appearance and 

layout of a worksheet 

 

 
 
Formulas: It contains commands to insert formulas.  
Data: It contains the commands to manage data. 

Review: It contains commands used to check spelling and protect 

worksheets, etc. 

View: It contains commands related to changing the view. Formula Bar 

The Formula bar displays the contents of the active cell. It can be used 

to enter or edit cell contents. The Formula bar contains three buttons, 

as shown below: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Figure – Formula Bar  
Cancel button: It is used to cancel the changes made in the cell. 

Enter button: It is used to commit the changes you made in the cell. 

Insert Function: It is used to construct formulas. 
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6.1 Workbooks 

  
An Excel file is called a workbook. In Excel 2013, each new workbook 

contains one blank worksheet. You can add additional worksheets. Each 

worksheet consists of 1,048,576 rows and 16,384 columns. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                                  

                                     Figure: Worksheet 

 

 

 

 

The box formed by the intersection of a row and a column is called a 

cell. Cells are used to store data. Each cell is identified by its address 

which consists of its column letter and row number. Example: cell 

A1 is the cell in the first column and first row. 
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Creating a Workbook 

You can start Excel 2013 from the Start menu. 

 

To start Excel 2013 from the Start menu: 
 
1. Click the File tab  new 
 
• It shows different templates. 
 
2. In the right pane, click 

Blank Workbook. It opens a 

new, blank workbook. 

 
3.You can also use Ctrl + N to open a new workbook.  
 
Saving a Workbook 
 
To save a workbook:  
1. Click the File tab click Save As.  
• It displays a Save As window 
 
2. Click Computer  Browse  
3. Select a location to save the file, type a name in the File name 

box, and then click the Save button. Note: Excel 2013’s file format is 

called Excel Workbook. This format has the file extension .xlsx 
Closing a Workbook 

After finishing working on a workbook, 

you can close it. To close a workbook 

without exiting Excel: 
 
1.Click the File tab, and then click Close. 
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2.Or, press Ctrl+W. 
 
Opening a 

Workbook to 

open a 

workbook: 

 

1.Click the File tab 

2.Then click Open. Or, press Ctrl+O. 

• It opens a list of recently used workbooks. 

3. Locate your workbook and then click the Open button. 
 
Entering Data  
You can enter the data directly in a cell or by using the Formula bar. A 

cell can contain a maximum of 32,767 characters. 

Entering Numbers  
Numbers are automatically aligned to the right in a cell. Numbers can be 

used in formulas to 

Calculate other values. 

You can enter: 

• Whole numbers (such as 5 or 1,000) 

• Decimals (such as 0.25 or 5.15) 

• Negative numbers (such as -10 or -5.5) 

• Percentages (such as 20% or 1.5%) 

• Currency values (such as $0.25 or $20.99). 
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To enter a number:  
1.Select the cell in which you want to enter the number. 

2.Type the desired number, and then press the Enter key.  
To edit data: 

1.Double-click the cell that contains the data you want to edit. 

2.Click where you want to make changes, and then type the new 

characters. 

3. To delete characters, click where you want to 

delete and then press the Backspace or Delete key. 

4.When you are finished, press the-+8 Enter key.  
Printing a worksheet: 

1.Select the worksheet that you want to print. 

2.Click the File tab  click Print. Or, press Ctrl+P. 

• Make the required changes in the print settings 
 
3. To print multiple copies, specify the number of copies you want. 
 
4.Click the Print button.   
Inserting a Worksheet: 

To insert a worksheet: 

1.Click the tab of the worksheet to insert a new worksheet. 

2.Click on Home tab  click on Insert and then click on Insert 

Sheet 

3.Or Click the New sheet button located on the right side of the tabs. 

This inserts a new worksheet. 

Charts 

A chart is an integral feature of Excel. It is also known as a graph. 

Charts/graphs are used to visually represent numeric values. It is very 

much useful to analyse the data
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6.2 Functions 
 

Functions are predefined formula that takes a value or values. A 

Function can perform an operation and returns a value or values.  
• • MS-Excel 2013 has a number of functions. Each function has a 

syntax. Syntax means a set of rules. 
 
An excel function has the following Syntax:  
1.A function must begin with '=' sign. 

2. Then, Define the name of the function 

3. Then, Specify the list of arguments in brackets.  
Types of Functions 

MS-Excel 2013 has the following types of functions: 

1. Statistical Functions 

2.Mathematical Functions 

3.Text Functions 

4. Logical Functions 

5. Financial Functions 

6.Date and Time Functions  
Statistical Functions: 

These functions will perform statistical operations. Some of them are:  
• Count: The COUNT function is used to count the number of cells that 

contain numbers. 
Syntax: COUNT (value1, [value2],) ([DPSOH  
&2817 
$$ 
 

 
Average: The AVERAGE function is used to find 

the average of values in a range of cells. 
 
Syntax: AVERAGE (number1, [number2] ...)  
Example: =AVERAGE (A2:A6) 

• Mid: The MID function is used to extract a substring. 
 
Syntax: MID (text, start_num, num_chars)  
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Example: = MID ("Microsoft Excel", 11, 5) 

It returns the value Excel. 

• LEN: The LEN function gives the length of the string. 
 
Syntax: LEN (text) 

 

Example: LEN ("MICROSOFT") 

It gives the value 9 

• Upper: Converts text to uppercase 
 
Syntax: UPPER (text)  
Example: UPPER ("excel") 

It gives the string EXCEL. Syntax: RIGHT (text, [num_chars]) 

Text Functions 

• Concatenate: CONCATENATE function joins the strings. 
 
Syntax: CONCATENATE (text1, [text2],) 

Example:=CONCATENATE("MICROS

OFT", " EXCEL") It gives the value 

Microsoft Excel  
• Left: The LEFT function is used to extract leftmost characters from a 

string. 

 

Syntax: LEFT (text, [num_chars])  
Example: =LEFT ("MICROSOFT", 5) 

It gives the value "micro".  
• Right: The RIGHT function is used to extract rightmost characters 

from a string. 
 
Example: =RIGHT ("MICROSOFT", 4)  
It gives the value "soft".  
• Mid: The MID function is used to extract a substring. 
 
Syntax: MID (text, start_num, 

num_chars) 

Example:=MID("Microsoft 
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Excel", 11, 5) It returns the 

value Excel.  
• LEN: The LEN function gives the length of the string. 
 
Syntax: LEN (text)  
Example: LEN ("MICROSOFT") 
 
Upper: Converts text to uppercase  
Syntax: UPPER (text) 

Example: UPPER ("excel")  
It gives the string EXCEL. Syntax: RIGHT (text, [num_chars]) 
 
 
Text Functions  
• Concatenate: CONCATENATE function joins the strings   . 

Syntax: CONCATENATE (text1, 

[text2],...) 

Example:=CONCATENATE("MICROS

OFT", " EXCEL") It gives the value 

Microsoft Excel  
• Left: The LEFT function is used to extract leftmost characters from a 

string. 

Syntax: LEFT (text, [num _ chars])  
Example: =LEFT ("MICROSOFT", 5) 

It gives the value "micro". 

• Right: The RIGHT function is used to extract rightmost characters 

from a string. 
 
Example: =RIGHT ("MICROSOFT", 4)  
It gives the value "soft".  
• Mid: The MID function is used to extract a substring 
. 
 
Syntax: MID (text, start_num, num_chars)  
Example: = MID ("Microsoft Excel", 11, 5) 

It returns the value Excel.  
• LEN: The LEN function gives the length of the string. 
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Syntax: LEN (text)  
Example: LEN ("MICROSOFT") 

 
, W JLYHV WKH
YDOXH   

Upper: Converts text to uppercase 
 
Syntax: UPPER (text)  
Example: UPPER ("excel") 

It gives the string EXCEL. 

Mathematical Functions 

• ABS: It returns the absolute value of a number. The absolute value 

of a number is the number without its sign.  
 
Syntax: ABS (number)   
Example: =ABS (-2) 

It returns the value 2. 

• COS: It returns the cosine of the given value. 
 
Syntax: COS (number)  
Example: COS (30) 

It returns the value 0.1542515 

• OR: It returns TRUE if any argument is TRUE; returns FALSE if all 

arguments are FALSE. 
 
Syntax: AND (logical1, [logical2],)  
Example: =OR (1+1=1, 2+2=5)  
• NOT: It reverses the value of its argument. 
 
Syntax: NOT (logical)  
Example: =NOT (FALSE) 

Financial Functions 

• FV: It returns the future value of an investment. 
 
Syntax: FV (rate, nper, pmt, [pv], [type])  
Example: =FV (A2/12, A3, A4, and A5) 

• PMT: It calculates the payment for a loan. 
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Syntax: PMT (rate, nper, PV, [fv], [type])  
Example: =PMT (0.50%, 240, 15000, 0) 

• PV: Returns the present value of an investment. 
 
Syntax: PV (rate, nper, pmt, [fv], [type])  
• Rate: It returns the interest rate per period of an annuity. 
 
Syntax: RATE (nper, pmt, PV, [fv], [type])  
Example: =RATE (A2*12, A3, A4)  
• NPV: It calculates the net present value 

of an investment. Syntax: NPV (rate, 

value1, [value2],...) 

 
Example: =NPV (A2, A3, A4, A5, A6)  
The result of formula is displayed in the cell that has the formula 

 
In Excel, every formula must begin with an equal to (=) sign. 
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Creating a Formula:  
Step 1: Select a cell to display the result 

Step 2: Type the = sign. 

Step 3: Type the cell address that contains the first number. 

Step 4: Type the operator you need in the formula  
Step 5: Type the cell address that contains the second number. 

Step 6: Press Enter. 

The expression will be calculated, and the result will be displayed in the 

cell.  
For example, you can write = A1+A2 to add the values in cells A1 and 

A2. 

Editing a Formula: 

Step 1: Select the cell that contains the formula. 

Step 2: The formula will appear in the formula bar. Click in the formula 

bar and change the formula. 

Step 3: Press the Enter key. 

Copying a Formula: 

• Formula specified in one cell can be copied and applied to other cells 

by clicking on the cell having the formula and then dragging the mouse 

across other cells. 

• While dragging, Excel automatically updates the cell references. 
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7. PRESENTATION 
 
Microsoft PowerPoint 2013 is a presentation program. It offers 

various themes and effects to create effective presentations. You can 

combine text, graphics, videos, sounds, and animations to create 

dynamic presentations.  
Microsoft PowerPoint can be used to create interactive presentations 

for classroom, business, or personal use. 

Features of MS-Power Point: 
 
1. By using power point you can create professional looking 

presentations. 
 
2. By using power point it is quick and easy to create presentations. 
 
3. It provides different templates and themes to create presentations. 
 
4.It provides various views to work with the slides. 
 
5. It provides features to insert other objects like charts, images, etc. 
 
6. You can create color or black & white overhead transparencies 
 
7. You can also create 35mm slides with different formats. 
 
8.You can create computer based presentations with several designs. 
 
9.You can also add animation effects to your presentation 
 
10. You can insert various multimedia objects such as audio, video in 

your slides. 
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PowerPoint contains the following menus/tabs:  
File: It contains the file management commands. 

Home: It contains the most frequently used commands. 

Insert: It contains the commands to insert other objects into a 

presentation 

Design: It contains the commands to change the appearance of a 

presentation 

Transitions: It contains commands to apply slide transitions. 

Animations: It contains commands to apply animation. 

Slide Show: It contains commands to present a slide show  
Review: It contains commands to review a presentation  
View: It contains commands to change the view. 

 

7.1 Creating a New Presentation 

  
In Powerpoint2013, You can create a new presentation in two ways:  
 
1.Creating a new blank presentation 
 
2.Creating a new presentation from a template. 
 
 

1. Click the FILE and select New.  
It displays a new presentation window. 

2. Click the Blank 

Presentation option. It 

creates a new blank 

presentation. 

OR 

Press Ctrl + N to create a Blank Presentation.  
Delete a slide 

1. Select the slide you want to delete. 

2. Press <Delete>. 
 
3.Right-click on the slide you want to delete and select Delete Slide.  
Editing a Slide 
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Most presentations require 

some editing. To edit text:  
1.Select the Slide 

2.Click where you want to edit. 

3.Do any of the following: 

• Type any additional text. 

• Press the Delete key/Backspace to remove text. 
 
Formatting Presentations  
PowerPoint 2013 has a number of features to format a 

presentation. Formatting enhances the appearance of a 

presentation. 
Changing the Theme  
A theme is a coordinated set of colors, fonts, and effects. You can 

easily change the theme for a presentation. 

To change the theme:  
1.Select--> Design tab--> select the desired theme from the Themes 

gallery.  
To insert Word Art 

1. Click on Insert --> WordArt. 

 

2.Select your WordArt.  
3.Enter the text 
 
1.Click on Insert > Table  
2.Choose the desired table size 

3.And then Click to insert the table.  
To insert Charts 

1.Click on Insert --> Chart. 

2.Choose a Chart. 

3. Click OK.  
 
Adding Custom animation   
Custom animation is a tool that gives motion to text, images, and other 

content on the slide. So that they appear on the slide automatically or 

with the click of the mouse. 
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Add custom animation  
Select the Slide 

Select an Element to apply animation 

• Click -->Add 

Animation button 

•Select an animation 

effect •Click the 

Timing tab  
• Apply the duration 

• Click the Preview button to preview animation 

Notes Page view 

The Notes pane is located beneath the slide window. It is used 

to include your notes in a presentation. 

Outline view 

Outline view is used to create an outline for your presentation. It 

displays only the text on your slide 
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7.2 Master views 
 

Master views include, Slide, Handout, and Notes. It is used to 

make universal style changes to every slide. 

Slide Show view 

Slide Show view is used to deliver your presentation to your audience. 

Slide Show view occupies the 

Full computer screen. 

Presenter view 

Presenter view can be used to view your notes while delivering your 

presentation. In Presenter view, your audience cannot see your 

notes. Reading view  
It is used to review a PowerPoint presentation. It makes it easy to move 

through the slides.  
An e-mail message contains two parts: 
 
1.Header 
 

2.Body • From: - Sender’s email address  
• To: - Recipients email address 

• Date: - When the e-mail was sent 

• Subject: The topic of the message 

• Cc:-Carbon Copy, to send the message to others. 

• Bcc:-Blind Carbon Copy, to send the message to others privately.  
 
 
Header: The header contains information about the message such 

as:  
Body: It contains the text of the message and any attachments to be sent. 
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8. INTERNET 

 
The internet is a network of interconnected networks. It is a global 

network of computer systems/devices. These computers are 

connected via cables, wireless, or via the cloud. Internet is mainly 

useful for information sharing. 

History of Internet: 

The Internet started in the 1960's under 

 

The name "ARPAnet". ARPAnet was originally developed for US 

military communications. This network operated with a technique called 

packet switching. 

The Computers on the Internet will use the Transmission Control 

Protocol/Internet Protocol (TCP/IP). These protocols are used to 

manage communication between computers. 

Today, the Internet has grown into a public giant network of millions 

of computers connected by cables and by wireless signals. 

Computers on the Internet use the client–server architecture. 

 

Internet Architecture  
The internet is a network of interconnected networks. It was designed 

to operate without a central control. 

The architecture of internet is hierarchical in nature. It contains the 

following components: 
 
1. Client: A Client is the user of a computer. It will be 

operated at the lowest level in the hierarchy. 

 
2. Local Internet Service Provider (ISP): It will be operated at the 

next level to the client. 
 



 

56 
 

ISP (Internet Service Provider): An ISP is an organization that 

provides the internet facility for their clients. Local ISP is the local 

telephone company. 

 

Example: BSNL, MTNL, Airtel 

 

 

 

 

Figure: Connecting to Interne
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Web Browser is an application program that can display the 

information on WWW. 

ISP is an internet service provider. 

A telephone line can transmit data from regional ISP to the client.  
Modem is a device that connects the computer to the internet. 

Internet Address  
A computer connected to the internet must have a unique address. 

This address is called Internet Protocol (IP) Address. It is useful to 

identify the computer uniquely. An ISP assigns a unique IP address to 

every computer in the internet.  
An IP address is a string of numbers. It contains 4 parts. Each part has a 

number between 0 and 255. For example: 192.168.54.122  
Domain Name: A domain name is a text name of the numeric IP 

address. Domain names are used for the convenience of the user. A 

domain will be provided based on the nature of their activities. For 

example:  
.com  for commercial organizations 

.Edu  for Educational institutions 

.net  for gateways 

.org for non-profit organizations 

.co  for 

Companies 

ac→ for 

academics 

 

Internet Services  
Internet offers a many services to the users. Some of the important 

services provided by internet are: WWW, e-mail, news, chat, and 

discussion groups. 
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9. World Wide Web 

 
The World Wide Web, or "Web" is a collection of documents. The 

World Wide Web was born in 1989. It was officially introduced on 

August 6, 1991 by Sir Tim Berners-Lee. 

• WWW uses hypertext. Hypertext is a document that contains links to 

other documents. 

• A hypertext document is called a webpage. 

• Webpages can be created by using a language called Hyper Text 

Mark-up Language (HTML). 

• Webpages can be transferred by using Hyper Text Transfer Protocol 

(HTTP). 

• A group of related webpages is called as a Web site. 

• The first web page of a website is called as Home Page. 

• A computer, which stores webpages in it is called as a Web Server. 

• The process of storing a web page on a web server is known as 

Uploading. 

• The process of retrieving a web page from a web server is known as 

Downloading. 

• A Web browser is an application program that can display the Web 

pages. 

• Every web page in internet can be identified by its address. This 

address is known as URL 

•  
 (Uniform Resource Locator). 
 

6.1 Electronic Mail  
An electronic message transmitted over a network from the sender to the 

receiver is known as an 

Electronic Mail. It is popularly known as e-Mail. An e-Mail has the 

following features: 
 
1. E-Mail is the fastest way to communicate with the people. 
 



 

60 
 

2. An e-mail can be sent to many persons at a time. 
 
3. An e-mail service is available 24hours a day. 
 
4. An e-mail can open his e-mail at his convenient times 
 
5. E-mail can also transmit other files as attachments with it. 
 
E-Mail Address: 

 

An e-mail address consists of 2 parts separated by @ symbol:  
The first part is User Name 

The second part is host computer name. 

For example: vcmgu@gmail.com 

Here, vcmgu is the user name. 

Gmail.com is the host computer name. E-Mail message format: 

An e-mail message contains two parts: 
 
3.Header 
 
4.Body • From: - Sender’s email address  

• To:- Recipients email address 

• Date:- When the e-mail was sent 

• Subject: The topic of the message 

• Cc:-Carbon Copy, to send the message to others. 

• Bcc:-Blind Carbon Copy, to send the message to others privately.    
 
 
Header: The header contains information about the message such 

as: 

 

 

Body: It contains the text of the message and any attachments to be 

sent. 32 Photographic Experts Group. It works well with 24 bit colour 

image. It is suitable for the images with many colors.  
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.GIF: GIF stands for Graphical Interchange Format. It supports 8 

bits of colour information. It is suitable for the images with 256 

colours. 

Audio: 

Audio consists of the sounds. In a multimedia project sound can be 

used for narration and also in backgrounds. 
Properties of Sound:  
Amplitude: It indicates the volume. It is measured in decibels. 

Frequency: It indicates the vibrations per second. It is measured in hertz 

(Hz). 

Bandwidth: It indicates the difference between the sound signals. 

Video: A Video consists of a sequence of natural scenes. A digital 

video can be used in making of movies, gaming and IT industry.  
4. Training: 

Multimedia can be useful to give training to employees. By using 

multimedia, training can be given online and also by using simulation. 

5. Virtual reality: 

Virtual reality is a special environment that can be created by using 

multimedia. It offers a feel of 3-D world. 

 

 

OUTCOMES: 

 
1.  Basic understanding of computer hardware & software 

2. Ability of problem solving skills 

3. Apply logical skills to programming in a variety of language 

4. Utilize web technologies 

5.  Basic understanding of network principles. 
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